Prerequisites

Supported Unity versions

Before starting the integration please check that you use one of the following Unity versions

  • Unity 2018, 2019, 2020. (NB: 2017 is unsupported but should be usable with special install instructions)
  • Unity Scripting Backend: IL2CPP and Mono
  • Unity Scripting Runtime Version: All stable .NET versions

Supported platforms

GameBench SDK monitors performance on the following platforms:

  • Android 5.0 or above
    • armeabi-v7a and arm64-v8a
    • If your game supports Android 4.1 and Android 4.4, GameBench SDK can be compiled but will not capture performance on these devices.
  • iOS 10 or above

We’ve tested this package with many devices, see our  device list.

GameBench account prerequisites

Make sure that you have an account on the GameBench Web Dashboard. You will need it to access the SDK and all the performance data later.

  • GameBench Cloud customers can access the Web Dashboard using this link.
  • GameBench Private server customers need to use their own link.

If your organization already uses GameBench tools, please ask your administrator to invite you and grant you “Manage All Data” and “Manage Company” permissions so you can create and manage projects yourself. Otherwise, your company administrator will need to create all the projects.