Requirements

To install and run the GameBench Android app you need to have the following:

  • Android v4.1.2 (or later)

  • Enable "Unknown Sources" under Settings > Security


After confirming these requirements, please see our Installation page.

Still need help? Get in touch!
Last updated on 11th May 2016